Category Archives: Yii 2.0.6 Released

Yii 2.0.6 Released

On August 5, 2015, Yii 2.0.6 was released. You can check out the official release announcement here.

This release has over 70 minor new features and bug fixes, including:

  • better migrations syntax
  • improvements in error handling
  • more control over ActiveForm using javascript
  • nested Yii::t() calls
  • extra session fields

I’ve looked over the changes and I don’t see anything that would conflict with the code in Yii 2 For Beginners.

Initially, when I tried to upgrade to Yii 2.0.6, I had problems and got an error:



  [UnexpectedValueException]
  Could not parse version constraint <=2.*: Invalid version string "2.*"

So I put in a request to the friendly forum and got the response I needed:

to fix this, do



composer global update #this will update the fxp which causes your constraint issue
composer update  

Once I did that, everything updated perfectly. I have not found any problems with my template using this update, so I think we’re all good. If anyone does notice something that fails due to version change, please let me know.

As always I appreciate the positive reviews, comments, and links. Thanks!

Advertisements